Fail to sync with Ledger+MetaMask after complex tx

Hi there, with Ledger+MetaMask I have some concerns about using complex smart contracts on Avalanche: almost each time I use the Defillama DEX agregator or Cian app (on Avalanche), I think my tx takes time to propagates because during approximately 1 hour, it’s just impossible to synchronize. MetaMask doesn’t succeed in connecting to RPC (even changing RPC twice…) and changing browser changes nothing. Sometimes, on 3 different browser, one is connected to Avalanche but my DeFi positions don’t appear. And after 1 hour, everything becomes normal again…
I had this answer from a guy in Defillama Discord (see image)

Did someone here had the same problem ? I also wonder if this is specific to MetaMask and/or Ledger; I tried to connect my Ledger with WalletConnect, but then it opened LedgerLive which proposed to link my ethereum account, not my Avalanche one - so I couldn’t finish my attempt… Note that the phenomenon doesn’t appear for usual transactions.
Thanks for help !

What browser are you using and does it change when using say Chrome vs another browser? Also, do you happen to be on a VPN?

I, happy to talk with someone else than a scammer :wink:
I don’t use a VPN and the problem happens with Brave, Chrome, and as well Avast browser. So I’m almost sure the problem is on-chain, probably when tx propagates ? Or maybe MetaMask can’t find the good nonce ?

I was told that it’s a rate limiting related as it seems to clear after an hour I was told, we’re going to try to ping someone on the team that may know the answer or can look into it more.

It would be great, thanks a lot ! :wink:

Yes I had exactly the same problem, using the Cian app or the Defillama DEX agregator. However the last time I used it with Cian, it worked perfectly but I don’t know why. I think this may be specific to MetaMask+Avalanche (Ledger has nothing to do with the problem here because tx are signed normally - as far as I know the only problem with Ledger is sometimes, signing messages is not proposed on some web apps). My decision was to stop using Defillama DEX agregator and Cian, so the problem doesn’t occur anymore.
It would be great to try with rabby wallet (download it from, which is better than MM anyway. If you try it, please let us know here if it failed or not.