Need help with Avalanche wallet and Ledger X

I have AVAX in an Avalanche Wallet and I would like to utilize my Ledger X to hold private keys. How do I integrate the two? I originally tried to withdraw AVAX from Binance to my Ledger but I could not get this to work so I used the Avalanche Wallet. I cannot find information as to how to properly use my Ledger. I already activated developer mode and confirmed that the Avalanche app is installed on my Ledger. I am unable to open the Avalanche Wallet with my Ledger and I am sure the private key remains in the Avalanche Wallet. How do I fix this? Any a help would be greatly appreciated.

Did you follow the instructions from here: https://docs.avax.network/build/tutorials/platform/setup-your-ledger-nano-s-with-avalanche

Note that Nano S is officially supported, although I heard reports that it works on the X too, I cannot confirm for sure.

You helped me yesterday with this on the troubleshooting Discord page. Since then, my Ledger froze on the PIN screen and I could do nothing to fix it. I am letting the battery die and hoping this unfreezes it. Not sure if the developer mode using AVAX wallet integration caused it or not. The only other assets I have on the Ledger are ATOM and ETH as well as IOTA via their Trinity integration.

I tried the version 0.4.0 on the developers mode in the Nano X and it worked fine, I open the wallet and can navigate through it. However, I haven’t passed tokens to that wallet, because I’m unsure if I lose functionality at some point since it is not the final version app for Nano X.
When that will be ready? any timelines?

With Nano X. Developer mode. Version .0.4.2 I have the same issue. I thought maybe I had to have ledger live running to get it to work but that is equally inconsistent. Frozen at the pin before. Battery drain does the trick. But for the life of me can’t figure out why the wallet sometimes does or doesn’t connect. Mac computer. Chrome browser.

Let me describe my (succesful) experience.

I have Ledger X. Noted that the Avalanche app is beta / experimental so I wanted some assurance that my AVAX would not be lost with it. For this purpose I did a test run where I imported a freshly generated throwaway seed from Ledger into the avalanchejs codebase and tried generating the same public keys and addresses as Ledger. I was able to do that which means

  • Even if the Avalanche Ledger app stops working or changes how it works in the future, I can recreate the wallet and private key without the app, just from my backup seed phrase.
  • Contrary to what I expected, there is no domain separation between Ledger apps so a bug or vuln in the beta Ava app could potentially put other coins on the same wallet at risk.

I also encountered some instabiilty as well as the complete freeze on PIN enter screen. I found that Ledger Live should not be running when using avalanche wallet with Ledger.

Hi Quiark. Thank you for this info. It is helpful. I’m on a mac and can confirm that I was trying to access the Beta wallet unsuccessfully over multiple days and without Live Ledger running. I was unsuccessful on all attempts. Just today, I opened up Ledger Live and as soon as I clicked on the “Manager” section. It worked. To date, this method is the only way I can get it to work properly.