I am facing this issue, Need help

ERROR[02-02|17:49:37] avalanchego/main/main.go#92: UPnP or NAT-PMP router attach failed, you may not be listening publicly, please confirm the settings in your router

Hello,

It might be a bit difficult to solve this kind of issue via the forum, it might be easier to dirrectly discuss with dev on discord : https://chat.avax.network/

However, as first thing, you might check if UPNP is activated in your router.

Also, in some router linked to some ISP, UPNP isn’t allowed, so it is just impossible to do it that way.

In this context, you need to force the public with --public-ip=X.X.X.X ( X.X.X.X = public IP ) parameter and you will have to manually create the port forward in your router :slight_smile:

Regards,

I tried this and now getting this

parsing parameters returned with error couldn’t create db at /home/[user]/.avalanchego/db/mainnet/v1.0.0: resource temporarily unavailable

It could mean that you already have a node running :slight_smile:

You can check using " ps " command and kill the old process

When you said " I tried this " => fixed UPNP or forced public-ip ?

Public-IP parameter is interesting if you are in an environment with a static IP or quite stable enough ( only change 2 - 3 times per year ), otherwise you might have to restart your node quite often :slight_smile:

Is it a node you are running at home or VPS ?

1 Like