Can not sign any metamask transactions with my ledger nano s device

hi guys,

recently i sent some of my avax on the c-chain to my metamask wallet, which is connected to my ledger nano s device. i wanted to swap it to png on the pangolin exchange. unfortunately, the transaction failed every time because i could not sign the transaction on my ledger. altough the device shows me the adresses and lets me accept the transaction, it fails every time at the end of the signing process.

i figured out that maybe it is not possible yet to make swaps on pangolin with a ledger connected metamask wallet - so i tried to send my avax to a non-ledger metamask wallet. but the same things happened there …

possible solutions i already tried out:

  • i changed the gas fee settings to 470/21000
  • i tried to not send the max amount of the avax which are currently in my wallet

i am grateful for any help

1 Like

Hello,

When you execute a swap on Pangolin => C chain, the fees should be 225 / XXXXXX ( normally the numbers are correct directly and you don’t have to do anything )

Example : image

When you execute a normal transaction on C chain between 2 metamask wallet for example, fees should be 225 / 21000

On a normal metamask wallet, do you have an error mentioned ?

Always keep a bit for the fees indeed.

Regards,

thanks for your answer! i tried out both settings, but again i received this error message at the end of the signing process (see below). my ledger just shows the screen “pending ledger review” after every try and i can not click it away in most cases (so i have to completely restart by removing the usb connection).

avax

for reference: my avalanche wallet is connected to the same ledger device as my metamask wallet. so after the transfer from the x-chain to the c-chain, my avax are showing up automatically in my metamask wallet. signing transactions from my avalanche wallet in the x-chain is no problem though. i only get the error when trying to do a transaction on the c-chain - regardless of whether it is the avalanche or the metamask wallet. so i can not even try to send my avax to a normal metamask wallet.

it seems there is some kind of issue with the avalanche ledger app while signing c-chain transactions.

Hello,

Ok, let’s try to make wallet work first.

=> Is Ledger Avalanche App well version 0.4.2 ?

=> Do you well use the wallet beta version " https://wallet-beta.avax.network/ " which is the one compatible with 0.4.2 ?

If yes, which browser do you use ?

=> Can you try using another one ? => Most of the issue I already heard with wallet were linked to people with Safari/Opera or Brave => Give it a shot with Chrome / Firefox / Edge

=> More rarely, someone had troubles whatever browser used => can you try your Ledger on another computer ?

Regards,

hi,

  1. yes it is version 0.4.2.
  2. yes i am using the beta version of the avalanche wallet with my ledger
  3. i am using the brave browser; i tried microsoft edge and firefox … did not work out as well (again error message at the end of signing process)
  4. right now i have no way to test it out on another computer but i will give it a shot when i have the chance to.

for reference: i tried transactions from my avalanche wallet to my metamask wallet AND from my ledger avalanche wallet to another non-ledger avalanche wallet.

by the way i tried to use a non-ledger wallet and there were no problems with c-chain related transactions (including swaps on pangolin).

so to use the c-chain it seems that there is no other way for me atm as to send my avax in my ledger avalanche wallet to a non-ledger avalanche wallet on x-chain - change there from x-chain to c-chain - and sending it from there to my non-ledger metamask wallet. i am glad we do not have this insane gas prices like on ethereum … otherwise i would be broke already.

would be interesting to see if somebody else has the same problems with c-chain transactions on a ledger wallet?

again thanks for your help!

Hello,

There were some issues 2 months ago, but didnt hear new ones for quite some time except the 2 i mentioned above.

1 ) Someone is forced to use Chrome browser otherwise he is always running with issues.

2 ) Someone was forced to used another device, His Ledger never accepted to work with his computer.

I will try to reach devs if they have an idea about this issue.

You can also ask your question directly on Discord => https://chat.avax.network

Regards,

short update should someone face the same problem in the future: it seems there is some kind of windows-related problem with the avalanche ledger app. so to validate c-chain transactions just switch to the ETH app just before you validate/sign the transaction. just be aware that “contract data” is allowed in the app settings. worked fine for me with metamask and pangolin!

1 Like