Avalanche Explorer: Only see 10% of my coins

When I search for my address in block explorer, I see a balance, that is 10% of the coins I bought at the ICO.

The coins are locked for 18 months, now about 6 months have passed, so it does not seem to be connected with this fact.

Do anyone have a idea, why this is the case or what I might have done wrong?

1 Like

On Avalanche Explorer, you are tracking the X chain.

Vested tokens aren’t on this chain. When they are unlocked, they are sent to P chain which isn’t tracked by explorer.

To check your token amount, you should better look directly in your Avalanche Wallet.

By the way, you look like to be from A2 pre-sale, and some vested tokens ( 15% ) where released in December.

Full unlocking planning here.

By default in the wallet you only see unlocked, unstaked tokens. Press the ‘show breakdown’ button in the Balance panel to see everything, including staked and/or locked tokens.

And, yeah, while you’re there: delegate those locked tokens for staking! You’re missing out on ~10% more tokens as a reward for staking.


I had the same issue. You can’t do anything with locked tokens other than stake them. I recommend using ALLNODES as it’s a very simply process to do.

Thank you very much for the info, never got the info for the partial unlock scenario before. Yes, my coins are from A2.

Searching on X-Chain shows balance of 10%, so it seems, that the first unlock is taken into account and the following 15% unlock is not in this view.

I could have activated the wallet, but I only have the PKs on cold wallet and I don’t want to activate wallet unless I can transfer everything immediately to hardware wallet. At time of key generation, I had no hardware wallet option. So I guess staking is also impossible.


If you don’t want to connect in your wallet, you won’t be able to stake indeed and you might miss 18 months of staking if you wait till the last tokens is unlocked.

There is something you can do to check your amount at the moment.

Connect on vscout.io

Search for your P-address => Switch X-Avax1… to P-Avax1…